Kinzersky.ru

Cisco

Подписаться на эту рубрику по RSS

Измерение скорости на маршрутизаторах Cisco

Просмотров: 8776Комментарии: 0
Cisco

У маршрутизаторов компании Cisco есть очень интересная, но недокументированная возможность. Начиная с версии IOS 11.2, Эта возможность может использоваться как анализатор скорости трафика между двумя маршрутизаторами. Но необходимо учесть, что нагрузка на маршрутизаторы может быть довольно большой, что может негативно сказаться на производительности устройств.

Необходимо проделать некоторые команды на обоих роутерах, между которыми производится проверка:

Приемник:

router1#ttcp
transmit or receive [receive]:
perform tcp half close [n]:
receive buflen [8192]:
bufalign [16384]:
bufoffset [0]:
port [5001]:
sinkmode [y]:
rcvwndsize [4128]:
delayed ACK [y]:
show tcp information at end [n]:
ttcp-r: buflen=8192, align=16384/0, port=5001
rcvwndsize=4128, delayedack=yes tcp

Отправщик:

router2#ttcp
transmit or receive [receive]: transmit
Target IP address: 172.31.1.2
perform tcp half close [n]:
send buflen [8192]:
send nbuf [2048]:
bufalign [16384]:
bufoffset [0]:
port [5001]:
sinkmode [y]:
buffering on writes [y]:
show tcp information at end [n]:
ttcp-t: buflen=8192, nbuf=2048, align=16384/0, port=5001 tcp -> 172.31.1.2
ttcp-t: connect (mss 1260, sndwnd 64260, rcvwnd 4128)

После окончания настройки, начнется поток трафика. После этого можно увидеть отчет, выглядящий примерно так:

ttcp-t: 16777216 bytes in 14588 ms (14.588 real seconds) (~1123 kB/s) +++
ttcp-t: 2048 I/O calls

По-умолчанию, отправитель отправляет чуть меньше чем 16 мб трафика, скорость при этом может не подниматься больше чем 8 Мб/сек. Чтобы попытаться генерировать больше трафика, необходимо увеличить параметр «receive window size» на отправителе.

Так же можно провести тест между маршрутизатором и ПК, используя утилиту TTCP на рабочей станции. Написана она для FreeBSD, но уже портирована под Windows. Эту утилиту так же можно использовать и как генератор трафика.

ip sla

Просмотров: 3827Комментарии: 0
Cisco

Обычно под данным термином при работе с оборудованием компании Cisco подразумевается проверка доступности определенного хоста в интернет или в локальной сети, а по результатам этой проверки производятся какие-либо действия. Например, устанавливаются статические маршруты, шлюзы по-умолчанию, выключения интерфейсов и т.д.

Соотв-но, ip sla это только один кусочек в мозайке всех технологий, которые доступны сетевому администратору.

track 100 rtr 100 reachability


ip sla 100
icmp-echo 192.168.0.1 source-interface FastEthernet4
timeout 6000
frequency 30
ip sla schedule 100 life forever start-time now

Проверяем (show track)

Track 100
Response Time Reporter 100 reachability
Reachability is Up
3 changes, last change 00:00:54
Latest operation return code: OK
Latest RTT (millisecs) 4

А дальше уже необходимо прикручивать остальные плюшки.

Горячие клавиши Cisco

Просмотров: 4571Комментарии: 0
Cisco

Сочетания клавиш Описание

Ctrl + I Обновить строку и перейти в конец

Ctrl + J Назад

Ctrl + K Удалить всё с права

Ctrl + L Обновить строку

Ctrl + M Назад

Ctrl + N Следующая команда

Ctrl + P Предыдущая команда

Ctrl + R Обновить строку

Ctrl + T Объединить два последних символа

Ctrl + C Новая строка

Ctrl + D Удалить правый символ

Ctrl + U Очистить строку и поместить её в буфер

Ctrl + W Удалить предыдущую команду и поместить её в буфер

Ctrl + X Очистить строку и поместить её в буфер

Ctrl + Y Вставить содержимое из буфера

Ctrl + E В конец строки

Ctrl + F Вернуть символ

Ctrl + H Удалить левый символ

Ctrl + A К началу строки

Ctrl + B Предыдущий символ

Cisco - управление работой интерфейсов по времени

Просмотров: 4228Комментарии: 0
Cisco

event manager environment _disable_int fa4

!

event manager applet DisableInt

event timer cron name DisableInterface cron-entry "0 23 * * *"

action 1.0 cli command "ene"

action 1.2 cli command "conf term"

action 1.7 cli command "int $_disable_int"

action 1.9 cli command "shut"

!

event manager applet EnableInt

event timer cron name EnableIntcron-entry "0 5 * * *"

action 1.0 cli command "en"

action 1.2 cli command "conf t"

action 1.7 cli command "interface $_disable_int"

action 1.9 cli command "no shut"

!

event manager applet EnableAfterReboot

event timer countdown name EnableAfterReboot time 5

action 1.0 cli command "en"

action 1.2 cli command "conf t"

action 1.7 cli command "interface $_disable_int"

action 1.9 cli command "no shut"

Cisco PPTP Server (+radius)

Просмотров: 5282Комментарии: 0
БезопасностьCisco

Настройки на Маршрутизаторе:
Код:
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default group radius local
aaa authorization exec default local
aaa authorization network default group radius if-authenticated
aaa accounting update periodic 1
aaa accounting network default
action-type start-stop
group radius
!
aaa accounting system default
action-type start-stop
group radius
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
ip mtu adjust
!
!
interface Virtual-Template1
description PPTP
ip unnumbered FastEthernet0/0
ip mtu 1400
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1300
peer default ip address dhcp
ppp encrypt mppe auto
ppp authentication ms-chap ms-chap-v2
!
ip radius source-interface FastEthernet0/0
!
radius-server host 192.168.1.110 auth-port 1812 acct-port 1813
radius-server timeout 30
radius-server challenge-noecho
radius-server key 7! указываем ключ который так же укажем на другой стороне радиус сервера
radius-server vsa send accounting
! 

Настройка NAT на Cisco

Просмотров: 3586Комментарии: 0
Cisco

int fa0/0 — внутренний (192.168.0.1/24)
int fa0/1 — внешний (172.16.0.1/24)

(config)#
делаем ACL:
расширенный:
ip access-list extended NAT
permit ip 192.168.1.0 255.255.255.0 any
или стандартный:
access-list 1 permit 192.168.1.0 255.255.255.0

включаем NAT на интерфейсах:
Внутренний:
Router(config)#int fa0/0
Router(config-if)# ip nat inside
Внешний: 
Router(config)#int fa0/1
Router(config-if)#ip nat outside

Задаем правило трансляции:
принцип: ip nat inside source <источник — и ACL> <назначение — интерфейс или нужный IP> overload
так:
ip nat inside source list NAT interface fa0/1 overload
или так:
ip nat inside source list 1 172.16.0.1 overload